23 March 2015

Breadboard power supply module destructive failure

If you have been shopping for DIY electronics lately, you have probably met the small board pictured here. It fits on the solderless breadboard and provides both 5V and 3.3V regulated output from a 6-12 Vdc input. My two specimens are marked "YwRobot Power MB V2 545043" and probably came from two online sources given that silkscreens look different.

/* If you are in a hurry, you can fast-forward to my conclusions right after the second picture. */

I used this one in my Arduino solar energy monitor and I noticed that AMS1117 regulators were getting pretty hot to touch. A Nano clone, an idle SD card adapter and an HD44780 display shouldn't drain that much current, and if they did they would be warm to touch too. [edit: the whole circuit draws about 50 mA except, I think, for those short moments it writes to the SD card once a minute.]

So I wanted to measure the input current, since that's the easiest point to insert an ammeter. I disconnected the positive lead from the 12 V PSU and inserted there my DVM ... the power adapter switched on but Arduino was behaving erratically. I did a power cycle and nothing happened anymore, no reassuring LEDs saying hello, not even on the YwRobot board.

The DVM internal fuse could have blown, so I restored the original 12 V positive lead and powered everything up.

Arduino LEDs were blinking awkwardly, or not blinking at all. Another wiring check confirmed that nothing had moved or shorted.

Just to be sure I measured if 5 V were still there and ... SURPRISE! I measured 12 V where I was expecting 5 V!

Since I was feeding 5 V directly to the Arduino board, it was fried (the FT232 USB-to-serial adapter survived, though!). The SD card adapter uses its own 3v3 regulator, so it was not damaged either.

I removed the power supply module and verified:
  • 5V output is now few hundred mV below input voltage, that's 12V or so
  • 3.3V output is not present anymore

What the heck is going on here? I decided to sacrifice my second power adapter module, that was equally heating up in my final application circuit.

This time I played it safer and removed the YwRobot adapter board from the solderless breadboard.

First of all, I wanted to know the idle current of the power adapter board alone. I removed it from the breadboard, added my DVM on the positive lead, fed 13V and the current drawn settled to ~20mA, which is fine according to AMS1117 datasheet (10 mA minimum load to keep regulating, and the board mounts two in series). After 5 seconds the board emitted the typical crackling sound of pine wood in the fireplace. And the unpleasant smell of burned electronics.

This time the DVM fuse didn't blow (10 A ;) ) and no other electronics were harmed.

The two broken adapters. Notice silkscreen differences... that don't make a difference!

Post-mortem analysis revealed that:
  • the AMS1117-5 (5V regulator) shows a resistance of 14 ohm between input and output pins
  • it passes through the input voltage
  • the first board's AMS1117-3.3 blew up, the second is still fine
I suspect that those YwRobot MB V2 boards go crazy if input lead lengths differ (I added about 100 cm of wire on the +V): both of them failed this way. What worries me is that failure breaks regulation and passes input voltage to the output pin instead of opening the circuit.

In both cases 220V AC to 12V DC was provided with a solid-state 5A PSU that mounts two 78M12 in parallel.

Curiously enough I find no mention elsewhere of this kind of failure. I do not own other YwRobot adapters and I do not plan to buy any more. Please let me know your thoughts in the comments.

Update 2020-04-28: Comments are closed.


Unknown said...

Mine fed by 9V delivers 8.4 V and 3.4 V. I guess the 5V regulator is 'broken' and not very pleased by the 3.3 accuracy. It's my first buy of this product. And may be the last.

ElecMech said...

First, thank you so much for posting your results - I thought I was losing my mind.

I just bought 13 of these boards from a U.S. eBay seller. I discovered the same problem on four of them off the bat - the input voltage passes right through the 5V regulator minus the (reverse voltage protection) diode. Of the remaining 9, I just powered one up and it got a short too (5 minutes after testing good).

I wonder if the manufacturer got a counterfeit batch of 5V regulators? In any event, this was supposed to go out to a customer this week and I'm now screwed. Won't be buying these ever again.

Paolo said...

Thank you @ElecMech and @Christophe for your comments. I am not sure what the cause is, but I am going to stick with my good old batch of 78(L)05. If I still have around my burnt YWrobot adapters I may lookup the manufacturer and try to write them.

The problem is now getting a reliable 3.3V source since more and more chips require that voltage supply.

CocosNucifera said...

have same problem with mine to. 5v reg is passing input voltage
3v3 reg seems to work ok... not fun when you put 12v into a 5v circuit :(

Swen said...

Same here - 5V line is nearly same voltage as DC-in, 3V3 is still fine. I've replaced the AMS1117-5.0 : Magic Smoke and 5V out ~ DC.in , 3v3 still OK... :(
going to salvage DC Jack, USB and switch ...
wouldn't buy it again.

Roberto said...

I have two of the same supply boards and seem to work fine.
On AMS1117 datasheet it is recommended to have at least 22uF on output line to have no stability issues. On the YWrobot adapters 100uF are mounted.
Another critical point can be the maximum input voltage. 12V are normally the maximum recommended while 15V is the absolute maximum rating.
The same 5V regulators I have seen on many Arduino nano low cost version (the same also using CH340G USB criver).
Often on these boards the output capacitor mounted are 4.7uF instead of 22uF minimum but nevertheless I do not remember any destructive failure on these device when supplied from Vin (i.e. through the AMS1117 regulator).


lunakid said...

Wow! Thanks for posting it!

Same here, too: two had the 5V reg. popped dead, with no good reason. (Run from a car battery, slightly below 13V.)

Note: on one of them the rev. pol. guard diode died, too.

What's going on?!

Paolo said...

@lunakid. Well, we might be abusing those regulators giving them an input voltage close to the absolute maximum rating: they might be off-spec parts and be less tolerant. But I reproduced the instability when DC_in leads were of different length, otherwise everything would keep working as expected.

A digital oscilloscope (with memory) could be used to see what goes on, but I do not have one and I will not but these modules again.

SElkind said...

Paolo's last comment rings true and led me to a little investigation into the AM1117 spec sheet.

Aside from any quality issues, it may not be input voltage that's killing some of these - directly. It may be power dissipation due to that high input voltage. Since I am about to start using one of these, branded "Elego" and labelled "Power MB V2" but which is otherwise similar, I did a quickie estimate of what may be "safe" - assuming the board is a "good" one.

Start with the board being very small, that it's shared by two AM1117's mounted right next to each other, and that I can't see through the layers. Then, I'd guess worst case heat dissipation, i.e., thermal coefficient 90 deg C/W from the spec sheet. A 200ma 3.3v load with a 12v input would mean the AM1117 is dissipating 1.74W - and would have a junction temperature of 156 deg C above ambient - say, 175-180 deg C at normal room temperature. The max junction temp in the spec is 125 deg C under continuous load. So, too hot. In theory the regulator should go into thermal shutdown at a temp of 165 deg C, but I don't want to test that out with my own project.

If the 5v AM1117 next to it is carrying a load, the ambient temperature could be a lot higher. So yeah, 12v is probably too much under anything but a light load.

Working backwards, just looking at 3.3v, the max "safe" output load currents, for different input voltages, would be at normal room temperature:

- 4.5v: 970ma
- 6v: 430ma
- 7.5v: 275ma
- 9v: 200ma
- 12v: 130ma

for 5v output:
- 6v: 1.0A (max rated output current)
- 7.5v: 460mama
- 9v: 290ma
- 12v: 165ma

Bottom line, use the minimum input voltage you can get for the largest safety margin, especially if you think the components may be iffy. The spec sheet says it can handle down to 1V drop-out voltage, so 6 or 6.5V might be the best choice - or 4.5-5V if you're only using 3.3V output.

Finally, if using both output voltages at the same time, I'd cut the above maxes by "a bit" (maybe up to 50%?) due to both devices trying to sink heat into the board and the air.

For example, I looked at the project I am about to start on - WiFi for my Arduino 101. The ES8266-01 could consume up to 250 ma at 3.3V, plus a level shifter chip at 5V and 3.3V (not sure of current). Based on the above, I just realized I shouldn't use the 9V wall wart I was about to use. Instead, I'll switch to a "universal" wall wart at its 6V setting.

petruchito said...

Almost same here, but i've noticed the input voltage on the 5V pin before i connected anything to it, +3.3V is just fine.
The board was just laying for a couple of months, connected without load to 12.5V supply.

Damaged by static electricity probably? Anyway I will never buy another one.

Unknown said...

I am glad to find all of your comments on the 12V shorting out throught the 5V output. Same happened to me on 2 boards bought a year ago. Good thing I checked before using this on a new project. These 2 boads worked previously. This is not an acceptable design for experimenter's projects.

Oleksiy.Tsebriy said...

When i connected my instance, i noticed the lcd becomes brighter and brighter. So I decided to check voltage. It was changing dynamically 8v and went higher 9v and so on. This is the first issue. However I encountered another one - I touched both 5v an gnd by the same ware mistakenly. This caused the effect described almost by all above. It passes almost all input to output. 7.7v output from 9v input, 11.1v output from 12v input.
Unfortunately my arduino got broken since it was powered through 5v and gnd pins. The same result with another instance. Now I am not sure I can rely on that even if I would use 6v input.

Graham Conroy Harris said...

I bought a batch of 10 of these from AliExpress. 7 now sit in my scrap box, 3 appear OK. Generally they failed just when I was testing them, before I connected anything of value to them.

mmmm1763 said...

Just burned an esp8266 esp01 module by connecting to it. I was powering the board with a 9V - 800mA power supply. Unfortunatelly the regulation board outputed 9V on the 3.3V rail and thus burned my module. Anyway, I learned to not trust shitty hardware from Aliexpress. And never again power supply modules without embedded protection circuitry.

Unknown said...

Glad I'm not the only one seeing this behaviour. Had mine pumping out 12v on the 5v lines last night while the 3.3v was still accurate. Had my CPLD dev board attached and am now hoping that hasn't been fried, not because it's expensive but because delivery time for a new one is a month or so!

Unknown said...

Same problem, just blew a RPI Zero W because of this.

IRC said...

I fried a ESP8266 last night due to this power supply passing through 9 volts on the 3.3 volt line. Think I bought 5 or so of these and have others that died and didn't destroy anything. They aren't cheap when they destroy your boards.

Mitch said...

I have 6 of these, haven't tested them all yet but the docs rate them at a maximum of 9v input. Not sure if that has anything to do with some of the failures see with higher voltage inputs.

Graham Conroy Harris said...

Pretty sure I haven't fed mine anything richer than 9v...

Mitch said...

Yeah and after running mine on 12v and feeling the 3v regulator get *really* hot, I dropped my input voltage to 6v just to be safe.

IRC said...

Probably 12v was my problem. I'll use 9v or less in the future. Shame that the failure mode is to pass the full 12v instead of 0v. Oh well, live an learn.

Paolo said...

So, the general consensus is that input voltage should be as low as possible, less or equal than 9V. But so far nobody commented on the fact that I blew both my adapters only when one input lead (say, positive) happened to be longer than the other. That's a normal condition when you insert an ampmeter in series. And smoke came instantly even without a load. Any taker that can sacrifice one MB102, ran at 9V input this time?

Shay said...

Count me in. I thought I was out of my mind testing a DSM501A dust sensor. Finally hooked a meter and saw signals > 5V, WTF? Then saw around 12V on the 5V. Tried another YuRobot board, same failure. Dust sensor seems to have survived, amazingly.

JPA said...

I think SElkind nailed it in this comment: http://ik1zyw.blogspot.com/2015/03/breadboard-power-supply-module.html?showComment=1471531357858#c2552063244171196798 .
I got one of this yesterday and i've been playing with it with a variable voltage source (one of this transformers with 4.5 - 5 - 7.5 - 9.5 - 12 - 15V output) and it actually seems to be an issue with the board's document rather than the board itself. It's a matter of how much power the AM1117 can dissipate without burning out. The document just says input voltage: 6.5 - 12V and "max output current" 700ma, but I would never plug anything that drains over 100ma if I'm using 12V input on this board. In fact, to be on the safe side, I'll consider a maximum output of 500ma while using 6.5v and keep a finger on the AM1117 to make sure they're not heating up too much.
Luckily enough I noticed the heating up before it was too late. I'll be using the board only with 7.5V from the transformer, or 12V from a small solar panel, which is perfect for this since it being rated at 1W max power output, it will never burn the board (anything over 83ma will just cause the panel to drop voltage).

tl;dr: I think that making sure the AM1117 doesn't dissipate over ~1 watt is being on the safe side :) Quite bad documentation for the board though.

JPA said...

Paolo the "having one lead longer causes this to burn" sounds very odd (like, why would it matter), any chance the longer lead was somehow coiled?

Your Neighbor said...

Did people verify that it was actually 12V input with no load?

At any rate glad I found your post here before I tried mine.
I plan on inserting a small fuse holder on mine, and another thing from my parts box, I might just use a buck down converter to sort of have it double regulated and keep the input at 6.5 volts or just above the minimal that makes a stable 5v output.

Also looks like it would be smart to put a load on the output and let it run for a few hours taking measurements once in a while. Like a 20 ohm 2w resistor for a 250ma load test.
It's rated at 700ma (while the chips are 1a) after all.
Be interesting to see how hot the 5v regulator chip gets.
Could take some thermal glue and glue a small aluminum heat sink over the regulators maybe.

Unknown said...

Recently bought one of these and before connecting anything to it, decided to test the outputs. Turns out i have around 7.9~8.2v on the 5v output and 4.9v on the 3.3v output... All of this with no load on it.

ok1fcu said...

I also have two dead boards of this type. While I am not quite sure if I didn't kill the first one accidentally, the second one sure was dead when unpacked. In both cases, the 5V regulator is shorted input to output. I would suspect counterfeit or defective batch of AMS1117-5 as mentioned before...

Unknown said...

I also had the same problem with those adaptors.
I found an explanation and a solution in a French hobbyst web site:
During module power failure, the electrochemical capacitor C2 (100μV / 16V) is still charged at approximately + 5V while the input of the IC1 regulator (AMS1117-5) has dropped to almost 0V. In fact, the output voltage being greater than that of its input, it circulates a reverse current inside the regulator, which can quickly (and even very quickly ...) leads to its destruction.
This phenomenon also applies to the second IC2 regulator (AMS1117-3.3) if an electrochemical filtering capacitor is connected to its output via the Breadboard.

Install a protective diode as shown in this picture:
With its protective diode, when the voltage at the input of the regulator disappears, the potential then becoming close to 0V, the cathode of the diode is more negative than its anode (still charged to the potential of the electrochemical capacitor) and the diode becomes conductive, while it is naturally blocked in steady state. The residual potential at the output of the regulator flows immediately to ground, instantly discharging the filtering capacitor (C2). The regulator is thus protected.

Unknown said...

The problem of reverse current cited above should never occur when you have a load connected. Wouldn't any load on the output immediately drain the capacitor? In any case, the burnouts that destroyed most boards discussed above, I believe, arose from excessive heat destroying the VR chips, not from 'reverse current'. Mine became very very hot with 100 mA load after a few minutes. Before burning my chips up, I installed heat sinks made from short segments of 1/4" copper tubing epoxied to both VR chips. In/out voltage difference must be kept to a minimum. If you want to use with more than minimal current load, you NEED to install heat sinks.